VICE/PRG aus D64 speichern

Aus C64-Wiki
Wechseln zu: Navigation, Suche
Baustelle Dieser Artikel befindet sich im Aufbau und ist vorläufig als Entwurf einzustufen.

Mit Hilfe des Emulators Vice aus einem D64-Diskimage einzelne Programme (PRG) speichern. Dabei ist zu beachten das mit den normalen Basic-Routinen nur Programmen mit weniger als ca. 154 Blocks gehandhabt werden können.

Schritt 1: Attach Image im VICE-Menü auswählen.[Bearbeiten]

1AttachImageMenu.png

Im File-Menü des Vice-Emulators den Punkt Attach disk image für die emulierte Floppy Drive 8 auswählen.

Schritt 2: Image auswählen.[Bearbeiten]

2AttachImageDir.png

Das D64-Image mit dem zu speichernden Programm auswählen.

Schritt 3: Programm mit Basic laden.[Bearbeiten]

3loadPRG.png
LOAD"$",8                Inhaltsverzeichnis des Image laden
LIST                     Inhaltsverzeichnis des Image anzeigen
LOAD"(programmname)",8   Programm laden


Schritt 4: Peripheral Settings im VICE-Menü auswählen.[Bearbeiten]

4PeripheraSettingslMenu.png

Peripheral Settings im Settings-Menü auswählen

Schritt 5: Verzeichnis statt Image wählen.[Bearbeiten]

5PeripheraSettingslDir.png

Bei Bedarf IEC-Device aktivieren.

Option Directory anwählen und das gewünschte Zielverzeichnis auswählen.

P00 sollte nicht aktiv sein, da dieser Filetyp für alte Emulatoren gedacht ist.

Schritt 6: Virtual traps im Vice-Options-Menü anwählen.[Bearbeiten]

6OptionsMenu.png

Damit das Programm ohne Image gespeichert werden kann, müssen "Virtual device traps" im Options-Menü aktiv sein, ansonsten liefert die Floppy-Emulation einen Drive Error.

Schritt 7: Programm mit Basic speichern.[Bearbeiten]

7savePRGrename.png
SAVE"(programmname)",8            Programm speichern

Das Programm wird im Dateisystem des PCs gespeichert. Achtung, SAVE klappt nur mit Programmen, die am BASIC-Start liegen und maximal 153 Blöcke lang sind.

Anschließend (bei Bedarf) im Dateimanager des Betriebssystem die Endung ".PRG" an den Dateinamen anhängen.